- - - By CrazyStat - - -

CMSimple_XH Dokumentation



— das kleine modulare Open-Source CMS ohne Datenbank

Voraussetzungen

CMSimple_XH wurde so entwickelt, dass es auf nahezu jedem Webserver ausgeführt werden kann. Für die Installation und den Betrieb gelten die in den folgenden Abschnitten angegebenen server- und clientseitigen Voraussetzungen.

Web-Server
CMSimple_XH 1.7 benötigt auf dem Server einen FTP-Zugang und mindestens PHP 5.3.
Es wird zumindest PHP 5.6 empfohlen und es wird auch PHP 7.x unterstützt.

Es wird keine Datenbank benötigt, da alle Daten in einfachen Dateien gespeichert werden.

Es wird ein Apache HTTP-Server empfohlen, aber CMSimple_XH läuft beispielsweise auch auf IIS und NGINX Servern.

PC
Auf dem PC wird ein FTP-Client benötigt um Dateien und Verzeichnisse auf den Server hoch bzw. von dort wieder herunter laden zu können und um Dateiberechtigungen auf dem Server ändern zu können.
Weiterhin wird ein Browser benötigt, um die CMSimple_XH-Website administrieren zu können.
Es wird die neuste Version von Firefox, Internet Explorer, Chrome, Safari oder Opera empfohlen.
Es ist zwingend notwendig dass JavaScript und Cookies aktiviert sind. Da Popup- und Werbeblocker unter Umständen wichtige Dialoge und andere Funktionen unterdrücken können, sind diese bei Bedarf zu deaktivieren oder es ist eine entsprechende Ausnahmeregel im Popup- bzw. Werbeblocker hinzuzufügen.

Erweiterungen
Einige Erweiterungen die nicht zum "Grundpaket von CMSimple_XH" gehören, können zusätzliche Anforderungen haben. Diese zusätzlichen Anforderungen sind der Dokumentation des jeweiligen Entwicklers der Erweiterung zu entnehmen.
Beispielsweise könnte solch eine Erweiterung ein Plugin sein, welches nur unter PHP 7 ausgeführt werden kann.